Back to overview
Downtime

We're running scheduled maintenance

Jan 03 at 12:30am +0530
Affected services
gradprints.lk

Resolved
Jan 03 at 12:37am +0530

The server upgrade has been completed. All services are now up and running.

Created
Jan 03 at 12:30am +0530

We're upgrading our servers for better performance. This may cause minor downtime.